[Mint 15] Cinnamon running in software rendering mode

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Re: [Mint 15] Cinnamon running in software rendering mode

Postby berndvondemberg on Sat Jun 29, 2013 2:59 pm

Apparently, fallback to software rendering happens irrespective of the hardware (AMD, Nvidia, and Intel gfx cards). At least after install. Did you guys make an EFI install? Or GRUB? Installing it in a virtual machine worked flawlessly, however.
berndvondemberg
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 27, 2013 2:16 pm

Linux Mint is funded by ads and donations.
 

Re: [Mint 15] Cinnamon running in software rendering mode

Postby nightcap on Sat Jun 29, 2013 10:49 pm

b7fLuid wrote:
Are earlier versions of Mint experiencing the same issues?


May I suggest installing Mint Cinnamon V.13? Installed V.13 successfully on at least 50 computers. Zero software rendering messages thus far (and none reported on-line that I've noticed). However you could be the odd one out? :)

Another slight advantage with V.13 is that it's LTS (Long Term Support) through to 2017 or thereabouts...............
inject linux /reject M$
nightcap
Level 1
Level 1
 
Posts: 23
Joined: Mon May 10, 2010 1:10 am

Re: [Mint 15] Cinnamon running in software rendering mode

Postby SkipG on Mon Jul 01, 2013 8:44 pm

For what it's worth, I'm a new adopter of LMDE Olivia 64bit. I tried both Cinnamon and MATE in a Parallels Desktop 8 emulator. At the time, I was using a Core 2 Duo Processor @2.8 GHz overclocked to 3.2 GHz. In the VM, I allocated 1 GB of memory, 1 processor, and 256 MB of Video memory to the video adapter. My Graphics card was an nVidia GT 240. I, too, was seeing the software rendering problem with Cinnamon, but it did not appear with the MATE desktop.

I recently upgraded my hardware by replacing my motherboard, memory, CPU and hard drives: I now have a 3.4 GHz quad core Ivy Bridge with 8 GB ram. This means I can allocate 2 CPUs to the VM and benchmarks show that performance has improved by almost a factor of 2. With this setup, I have no problems with software rendering whatsoever. I really like Cinnamon, and it's working great in my emulator. I moved my old hardware to another box, and installing LMDE Cinnamon on the real hardware also works.

In my case, I think the issue was inadequate horsepower to drive the display in the VM.

EDIT:

In my case the problem was due to the prl-xll startup script. See http://forum.parallels.com/showthread.php?288091-Please-Fix-Parallels-Tools. The script has been fixed in PD9

--skip
Last edited by SkipG on Thu Oct 24, 2013 8:02 am, edited 1 time in total.
SkipG
Level 1
Level 1
 
Posts: 7
Joined: Mon Jul 01, 2013 8:19 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby opaArt on Fri Jul 05, 2013 2:19 pm

Mint 15 Cinnamon startup message "Running in software rendering mode. Video acceleration is disabled." I think is false. According to my experience this is a Mint 15 software glich. I did a Mint 14 re-install, and am running Windows 8 64 bit on seperate hard drive, using dual boot system, and experiencing no problems. Checked CPU usage on both systems. Re-installed Mint 15 64 bit, got the same annoying message, but CPU usage and video display are all the same as with Mint 14. I now click on the message to make it go away.
opaArt
Level 1
Level 1
 
Posts: 7
Joined: Sat Mar 01, 2008 6:39 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby berndvondemberg on Fri Jul 05, 2013 4:47 pm

opaArt wrote:Mint 15 Cinnamon startup message "Running in software rendering mode. Video acceleration is disabled." I think is false. According to my experience this is a Mint 15 software glich. I did a Mint 14 re-install, and am running Windows 8 64 bit on seperate hard drive, using dual boot system, and experiencing no problems. Checked CPU usage on both systems. Re-installed Mint 15 64 bit, got the same annoying message, but CPU usage and video display are all the same as with Mint 14. I now click on the message to make it go away.


For the MacMini (HD 4000) it is definitely not just a message. CPU goes up, software rendering is sluggish and there is no true color mode anymore.
Best
berndvondemberg
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 27, 2013 2:16 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby stormhike on Wed Jul 10, 2013 9:28 pm

I managed to get my R7750 Radeon card working properly with Mint 15 (and Mint 14).
I installed the fglrx-updates driver from the additional drivers dialog and then in a terminal typed in the command: sudo aticonfig --initial.
After rebooting I ran glxgears from a terminal and got an FPS greater than 3000. Videos run really well too.
To start with I installed the driver without the aticonfig command; but after reboot I had no mouse cursor.
It seems that installing the driver does not update xorg.conf, that's why aticonfig is needed.
stormhike
Level 1
Level 1
 
Posts: 2
Joined: Fri Nov 18, 2011 1:16 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby nightcap on Fri Jul 12, 2013 5:47 am

stormhike wrote:I managed to get my R7750 Radeon card working properly with Mint 15

Great! Will test on my PC over the weekend. For clarity, have you achieved:
1. No more "software rendering" warning pop-up?
2. No undue CPU overload? (Idle well below 10%?)
inject linux /reject M$
nightcap
Level 1
Level 1
 
Posts: 23
Joined: Mon May 10, 2010 1:10 am

Re: [Mint 15] Cinnamon running in software rendering mode

Postby stormhike on Fri Jul 12, 2013 1:23 pm

nightcap - yes no "software rendering" message at start up and quiet(ish) CPU. Not sure how you measure CPU ( I have a quad core), using 'top' in a terminal shows cinnamon running under 3% and Xorg under 2%, both with occasional spikes depending on activity. Hope this helps.
stormhike
Level 1
Level 1
 
Posts: 2
Joined: Fri Nov 18, 2011 1:16 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby nightcap on Sat Jul 13, 2013 9:26 pm

Success! Following stormhike's method, all good. Thanks. No annoying pop-up, (quad) CPU cores all idling below 1%. (Check under System Tools -> System Monitor) Will monitor video stability and performance.

Unsure if this thread can be marked solved. Any others tried this, and found their fix?
inject linux /reject M$
nightcap
Level 1
Level 1
 
Posts: 23
Joined: Mon May 10, 2010 1:10 am

Re: [Mint 15] Cinnamon running in software rendering mode

Postby JKmac on Sat Aug 03, 2013 2:58 pm

b7fLuid wrote:Hey guys,

Are earlier versions of Mint experiencing the same issues?


I have found same problem with Mint 15 running quad AMD machone. Good news is: I'm running Mint 13 just fine and since I found this in Virt Box and saw graphics issues with live CD decided against install.

Mint 13 is based on Ubuntu 12.04 LTS so should be good solution until this gets resolved.

MAJOR bad for Mint team. First black eye I've seen them get. Now let's see how they handle it.

Well MINT guys--- how are you going to handle it?
JKmac
Level 1
Level 1
 
Posts: 5
Joined: Sun Mar 04, 2012 3:06 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby nightcap on Mon Aug 05, 2013 8:59 pm

Another update. Finding grafx issues after installing fglrx-updates driver. Slight transition glitches when minimizing desktop windows. Also screenshot packages fail to grab immediate desktop image or selected area. These include Shutter and Gnome Screenshot. There may be other grafx issues yet to be discovered. This proprietary AMD fglrx-updates driver is a work in progress?

It would seem churlish to be critical of Mint development, given the pace, scale and grunt required to maintain high standards of Linux coding for extended periods. After all, this is not corporate, but by a community for the wider community. Ever so slightly bleeding edge. Arguably, currently, state-of-the-art.
inject linux /reject M$
nightcap
Level 1
Level 1
 
Posts: 23
Joined: Mon May 10, 2010 1:10 am

Re: [Mint 15] Cinnamon running in software rendering mode

Postby vaxi on Tue Aug 06, 2013 6:24 pm

Thank you Stormhike. I did the same thing and it worked for me too...
vaxi
Level 1
Level 1
 
Posts: 1
Joined: Tue Aug 06, 2013 6:18 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby PizzaGuy on Sat Aug 17, 2013 3:08 pm

I installed the fglrx-updates driver from the additional drivers dialog


Hi all,

I've also got this software rendering problem. I've got 2 installs with Linux Mint, one 64 bit and the other 32 bit. The 64 bit is working great. The 32 bit, however, has the rendering issue. I've searched the several times over the past several weeks and have tried a few things but no (proper) solution as yet.

One clue: What I have found is if I switch to a different desktop, "Xfce", then it has no rendering issues at all. But the Cinnamon interface stubbornly doesn't give up rendering, and that's the one I'd prefer it use.

Kernel: 3.8.0-27-generic
Processor: Intel Pentium Dual CPU E2160 @ 1.80GHz x 2
Graphics card: VIA Technologies, Inc P4M890 S3 UniChrome Pro

I tried following the instructions above but have no idea where the "additional drivers dialog" can be found. Thanks for any/all help! LinuxMint is great. I was on Ubuntu until they migrated to the Unity interface which I couldn't stand for PC use. Very glad to see Mint carrying on that market.
PizzaGuy
Level 1
Level 1
 
Posts: 3
Joined: Sat Aug 17, 2013 2:27 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby zenithyr on Thu Aug 22, 2013 11:13 pm

Same.

ATI - 7750, I5 3750K with on-board HD4000. Default video card driver is slow and laggy.
zenithyr
Level 1
Level 1
 
Posts: 1
Joined: Thu Aug 22, 2013 11:09 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby tekdad on Sat Aug 24, 2013 9:22 am

THIS IS FOR INTEL GRAPHICS -

Just fixed my mother's PC stuck in software rendering mode. I tried everything in this thread, plus some more. This is what fixed it.
From here.

Code: Select all
$ sudo cp /etc/lsb-release /etc/lsb-release.bak
$ sudo pico /etc/lsb-release


"Replace with (I'm not sure exactly which lines are being checked here by intel-linux-graphics-installer, but definitely not the last one.)

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.04
DISTRIB_CODENAME=raring
DISTRIB_DESCRIPTION="Linux Mint 15 Olivia"
"
THIS IS FOR INTEL GRAPHICS -
And then from here.
Code: Select all
echo "deb https://download.01.org/gfx/ubuntu/13.04/main Ubuntu 13.04 #Intel Graphics drivers" | sudo tee /etc/apt/sources.list.d/intellinuxgraphics.list

Code: Select all
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | sudo apt-key add -
sudo apt-get update

THIS IS FOR INTEL GRAPHICS -
Then:
Code: Select all
sudo apt-get dist-upgrade

(but make sure this command doesn't try to remove any packages and if for some reason it does, abort and disable the repository) - mine did not.

reboot, and it was fixed. No software rendering mode warning, no high CPU usage, and all videos and content played and scrolled smoothly.

This was for intel, but I am looking for a similar fix for both nvidia and ati.

Let me know how it goes if you have this problem with Intel Graphics drivers. There went two weeks that I'll never get back.
tekdad
Level 1
Level 1
 
Posts: 1
Joined: Sat Aug 24, 2013 9:11 am

Re: [Mint 15] Cinnamon running in software rendering mode

Postby PizzaGuy on Mon Aug 26, 2013 12:50 am

Thanks for the suggestion, but no dice for me. Doesn't appear I'm running intel graphics but followed it anyway. Every command went smoothly, but still got rendering.

I've since installed KDE on it which would be fine and which doesn't render, but for some reason can't adjust the screen res to the max allowed by the monitor.

Oh well. I'll keep working on it.
PizzaGuy
Level 1
Level 1
 
Posts: 3
Joined: Sat Aug 17, 2013 2:27 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby PizzaGuy on Sat Aug 31, 2013 1:01 pm

Okay all. here's the final rundown for me. I've installed mustiple desktop interfaces. On my 32 bit system:

Cinnamon didn't work because it insisted on running with software rendering. It was the only one with that problem.

Xfce wouldn't save the display settings. Every time I log in, it sets to a low screen res and I have to go to display settings to reset it to the hightest supported. Also, Xfce didn't have the best interface for my preferences.

Then I tried KDE. Great interface, but the problem there was the screen was set to a low res and KDE wouldn't even let me change it to the max the monitor could handle (It's a small monitor with 1280x720 resolution, and the KDE specs I read did say it required a min 768 vertical resolution). For whatever reason, the Display settings window under KDE was completely blank. I couldn't change the screen resolution at all.

Then I installed MATE. Great interface, no software rendering, screen resolution can be set to the max suported by the monitor, and it remembers the correct resolution between logins. Everything works as it should, so that's the new desktop for that system. Thanks to the crew behind the MATE desktop. :D
PizzaGuy
Level 1
Level 1
 
Posts: 3
Joined: Sat Aug 17, 2013 2:27 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Postby deevla on Mon Oct 07, 2013 5:06 am

Greetings to all

I've just made a switch from Ubuntu (gnome-shell), to mint 15 (cinnamon), and i have exactly the same problem as described in first post, using amd hd6850 and fglrx both from repo and from amd website.
I think this bug is related to gnome3, since i had the same problem in ubuntu, and Workaround was to use gnome-tool, and set "have file manager handle the desktop" to OFF. With that option disabled i had no problem with black background, conky transparency..
But there's no such option in mint, or i can't find it. So i'm sticked with open source drivers, and much lower performance.
deevla
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 07, 2013 4:54 am

Re: [Mint 15] Cinnamon running in software rendering mode

Postby threadofmotion on Tue Oct 15, 2013 1:01 am

stormhike's method worked for me!

My system info:
AMD FX(tm)-6300 Six-Core Processor
AMD ATI Radeon HD 7750
15.7 GB Memory

1. Switch driver to fglrx-updates
2. sudo aticonfig --initial
3. reboot
4. CPU load down from ~60% to ~10%
threadofmotion
Level 1
Level 1
 
Posts: 1
Joined: Tue Oct 15, 2013 12:57 am

Re: [Mint 15] Cinnamon running in software rendering mode

Postby svaughn on Mon Feb 10, 2014 3:24 pm

I told a friend of mine about this problem and he suggested simplifying the /etc/X11/xorg.conf file

He gave me the following code to use:

Code: Select all
Section "Monitor"
  Identifier "Monitor0"
  HorizSync 38-75
  VertRefresh 50-75
EndSection

Section "Screen"
  Identifier "Screen0"
  Monitor "Monitor0"
  Device "Card0"
  DefaultDepth        16
  SubSection "Display"
    Depth         16
    Modes         "1280x1024" "1152x768" "1024x768" "800x600"
  EndSubSection
EndSection


Once I did that (and restarted the mdm service), the CPU utiliztion when from about 85% (on my 850MHz Celeron) to less that 1%

I'm not sure what I am lossing by cutting out all the additional screen and monitor sections
svaughn
Level 1
Level 1
 
Posts: 1
Joined: Mon Feb 10, 2014 3:20 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Cinnamon

Who is online

Users browsing this forum: bob2 and 5 guests