Log in screen resolution problems

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Log in screen resolution problems

Postby crispygoat on Thu Jul 30, 2009 6:55 pm

I tried connection another screen today. After doing so, the log in window's resolution became lower.

Any help on how to change the log in screen resolution back to default?
crispygoat
Level 1
Level 1
 
Posts: 11
Joined: Thu Jul 23, 2009 4:01 pm

Linux Mint is funded by ads and donations.
 

Re: Log in screen resolution problems

Postby cmost on Thu Jul 30, 2009 8:01 pm

Well, the way I always control the resolution of the GDM screen is to include the "Virtual" parameter in my /etc/X11/xorg.conf. Now I realize the latest version of Mint includes a very rudimentary xorg.conf since most things are autodetected these days. Nevertheless, you can use your own xorg.conf and it will override any default settings. Make sure you have something like the following in your xorg.conf:

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultColorDepth 24
SubSection "Display"
Depth 24
Modes "1680x1050" "1440x900" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
Virtual 1680 1050
EndSubSection

Obviously, you would set resolutions relevant to your monitor. Whatever your desired resolution, just add the line "Virtual" below the "Modes" and set it to the resolution you want (i.e., 1680 1050 in my case.) Note: there should NOT be an "x" between the horrizontal and virtical resolutions in the "Virtual" line.

Good luck!
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Re: Log in screen resolution problems

Postby crispygoat on Tue Sep 01, 2009 11:15 pm

It did not fix the problem. My xorg.conf file looks like,

Code: Select all
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   SubSection "Display"
      Virtual   1360 1632
   EndSubSection
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "ServerFlags"
   Option   "DontZap"   "False"
EndSection


Changing Virtual did not work. Any other ideas?

thanks
crispygoat
Level 1
Level 1
 
Posts: 11
Joined: Thu Jul 23, 2009 4:01 pm

Re: Log in screen resolution problems

Postby cmost on Wed Sep 02, 2009 6:37 pm

I don't think you can use the "Virtual" line without a corresponding "Modes" line. For the login, X will default to the first resolution defined in the “mode” entry. Therefore, you must select the resolution you want (i.e., “1280×1024″) and move it at the first position. The “Virtual” entry is typically used to have a larger desktop resolution than screen resolution (you can reach the zones “outside the screen” by moving your mouser pointer to the edges). Your Virtual section should have the same size you want for the login resolution (say 1280 1024).

Another way to control GDM's resolution is to use xrandr

You can direct xrandr to set a different resolution using the following command
Code: Select all
xrandr --output VGA --mode 1024×768 --rate 75


Add undetected resolutions

Due to buggy hardware or drivers, your monitor’s correct resolutions may not always be detected

If the mode already exists, but just isn’t associated for the particular output using the following command

Code: Select all
xrandr --addmode VGA 1024×768


Note: Changes you make using xrandr only last through the current session.

Set xrandr changes persistently

There are several ways to make xrandr customizations permanent from session to session:

a) .xprofile

A user’s ~/.xprofile file is executed on Xorg startup if it exists and is executable. You can copy and paste xrandr command line strings into this file so they’re executed when you log in

b) kdm/gdm

Both KDM and GDM have startup scripts that are executed when X is initiated. For GDM, these are in /etc/gdm/, while for KDM this is done at /etc/kde4/kdm/Xsetup. In either case, you can paste in an xrandr command line string into one of these scripts.

This process requires root access and mucking around in system config files, but will take effect earlier in the startup process than using .xprofile, and will apply to all users including the login screen.
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 34 guests