Linux mint 13 kde x server problem

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Linux mint 13 kde x server problem

Postby 10tacl3 on Fri Feb 08, 2013 6:21 am

Hello, I'm using Linux mint 13 KDE and after i upgraded to kde 4.10, before the graphical login screen i have a text one and i have to type "sudo startx" from there to start my desktop....why isn't it automatically anymore? how can i fix it? Thanks in advance!

P.S I should mention that one time starts using graphical interface and another time using text
10tacl3
Level 1
Level 1
 
Posts: 2
Joined: Fri Jul 13, 2012 4:54 pm

Linux Mint is funded by ads and donations.
 

Re: Linux mint 13 kde x server problem

Postby 10tacl3 on Tue Feb 12, 2013 5:33 am

i don't know why do they say this is a great community, i look at other user topics and it's about the same...well, good luck everyone!
10tacl3
Level 1
Level 1
 
Posts: 2
Joined: Fri Jul 13, 2012 4:54 pm

Re: Linux mint 13 kde x server problem

Postby jazz.h on Fri Feb 15, 2013 4:21 pm

Hi!
This happened to me too, today. I wrote about it here -> http://forums.linuxmint.com/viewtopic.php?f=109&t=124912#p687748
Did you find the solution for startx to start automatically?
Other than that, does KDE 4.10 runs ok for your Mint13KDE? I didn't encounter a single problem, besides startx...
jazz.h
Level 4
Level 4
 
Posts: 243
Joined: Sat Jun 18, 2011 7:13 am

Re: Linux mint 13 kde x server problem

Postby Siarra on Fri Feb 15, 2013 8:52 pm

Same issue here. It seems to be related to the Nvidia drivers. When I purged Nvidia drivers x was loading properly (obviously without all eye candy 3D effects and stuff). What i did already:
sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get -f install
sudo apt-get dist-upgrade
No errors at all, reboot and bang. X is not loading and stops on command line tty1. When I logged in I couldn't run 'sudo /etc/init.d/kdm start' because it looks like something is actually loaded. The workaround is to run:
sudo /etc/init.d/kdm stop
then after
sudo /etc/init.d/kdm start
After that the X and KDE 4.10 is loading and everything is working flowlessly.

Any ideas how to fix it?

I already tried to install couple of different versions of Nvidia drivers but it doesn't change anything.
Siarra
Level 1
Level 1
 
Posts: 5
Joined: Fri Apr 30, 2010 10:19 am

Re: Linux mint 13 kde x server problem

Postby Siarra on Sat Feb 16, 2013 6:32 pm

I found the solution here http://askubuntu.com/questions/37084/nv ... not-in-use
I was just missing kernel headers after kernel upgrade.
So steps to resolve were:

Install the kernel headers for my version of kernel
sudo apt-get install linux-headers-3.2xxxxxx
sudo apt-get install linux-image-3.2xxxxxx
I used synaptic as they were all listed there ;)
then
ctrl+alt+f1 and log in to the console
sudo /etc/init.d/kdm stop
sudo apt-get purge nvidia*
sudo apt-get autoremove
sudo apt-get -f install (just in case)
sudo dpkg-reconfigure xserver-xorg (just in case again)
sudo reboot
ctrl+alt+f1 and log in to the console
sudo /etc/init.d/kdm stop
sudo apt-get update
sudo apt-get install nvidia-experimental-310 nvidia-settings-experimental-310 kde-full
sudo reboot

Issue resolved ;) KDE 4.10 loading perfectly :)

Best of luck to all KDE fans :)
Siarra
Level 1
Level 1
 
Posts: 5
Joined: Fri Apr 30, 2010 10:19 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], Google Feedfetcher, jewnersey, mattmart683 and 18 guests