Numlock wanted ON by default

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Re: Numlock wanted ON by default

Postby johnglid on Sat Aug 11, 2012 10:22 pm

Found the solution here "http://nancib.wordpress.com/2011/12/17/howto-run-scripts-in-kde-before-kde-starts/"... Informative article.
johnglid
Level 1
Level 1
 
Posts: 4
Joined: Wed Aug 08, 2012 8:40 pm

Linux Mint is funded by ads and donations.
 

Re: Numlock wanted ON by default

Postby marsh20 on Wed Aug 15, 2012 4:51 am

Hi all,

Sorry to resurrect this thread.

I am running LM 13 Mate and have tried the suggested fix from Nomko early in this thread and does not seem to have had any effect.

Any other suggestions?
Think about the "undo" before you "do".
User avatar
marsh20
Level 3
Level 3
 
Posts: 156
Joined: Thu Dec 15, 2011 5:44 am
Location: UK

Re: Numlock wanted ON by default

Postby marsh20 on Fri Aug 17, 2012 4:34 pm

Hi All,

I think I screwed up my etc/mdm/init/default its now totally blank any advise how to get the default back?
Think about the "undo" before you "do".
User avatar
marsh20
Level 3
Level 3
 
Posts: 156
Joined: Thu Dec 15, 2011 5:44 am
Location: UK

Re: Numlock wanted ON by default

Postby claudecat on Fri Aug 17, 2012 5:39 pm

For me the setting in System Settings under Input Devices to turn on numlock did not work. What did work was to install numlockx (sudo apt-get install numlockx) and then in System Settings under Startup and Shutdown/Autostart click Add Program and type in numlockx. This has worked in several distros in which the KDE setting does not.
claudecat
Level 3
Level 3
 
Posts: 115
Joined: Wed Mar 03, 2010 1:03 am
Location: MD, USA

Re: Numlock wanted ON by default

Postby kaspin on Sun Mar 03, 2013 9:37 am

Thanks for that claudecat. It worked fine on my French keyboard in LDME (Cinnamon) :D , whereas 3 or 4 other suggestions from elsewhere didn't :( . Have recently changed, after several years with Ubuntu (didn't like 12.04) and find the contributors to the LMDE fora (o.k. forums) much less pompous.... Thanks again, Kaspin
kaspin
Level 1
Level 1
 
Posts: 8
Joined: Mon Feb 25, 2013 1:01 pm

Re: Numlock wanted ON by default

Postby blueknight529 on Fri May 24, 2013 9:55 am

sudo apt-get install numlockx

- Now edit /etc/mdm/Init/Default and insert the bellow code.

sudo gedit /etc/mdm/Init/Default (or use vi, nano, leafpad, etc as the editor instead of gedit)
and insert these lines at the end of the file, just before "exit 0":

if [ -x '/usr/bin/numlockx' ];
then
/usr/bin/numlockx on
fi

- Save & Exit editor program


It is done. :-)
blueknight529
Level 1
Level 1
 
Posts: 5
Joined: Mon May 18, 2009 11:19 am

Re: Numlock wanted ON by default

Postby inhiway on Sat Jun 01, 2013 8:02 pm

+1
Intel i7-920, nVidia GT430, 6 GB RAM, Linux Mint 17 KDE x64 , Windows 8.1+
Linuxux User #454271
inhiway
Level 1
Level 1
 
Posts: 32
Joined: Sun Nov 14, 2010 10:36 pm

Re: Numlock wanted ON by default

Postby TheOne on Sat Jun 01, 2013 10:18 pm

blueknight529 wrote:sudo apt-get install numlockx

- Now edit /etc/mdm/Init/Default and insert the bellow code.

sudo gedit /etc/mdm/Init/Default (or use vi, nano, leafpad, etc as the editor instead of gedit)
and insert these lines at the end of the file, just before "exit 0":

if [ -x '/usr/bin/numlockx' ];
then
/usr/bin/numlockx on
fi

- Save & Exit editor program


It is done. :-)



Thank you so much!
Capitalists for the use of Linux and open software.
http://2briancox.wordpress.com/2011/07/ ... -software/
User avatar
TheOne
Level 1
Level 1
 
Posts: 21
Joined: Tue May 28, 2013 10:29 am

Re: Numlock wanted ON by default

Postby stilloving on Sat Jun 29, 2013 8:12 am

This method enable numlock during login and after login, so you have the numlock always ON in your LINUX MINT and LMDE

1) FIRST, install numlockx : sudo apt-get install numlockx

2) SECOND, go to menu and type startup application and opent it.

3) Click on +add

4) On "Name" put NUMLOCK ON

5) On "Command" put /usr/bin/numlockx on

6) Click on "+add" and "close" .


7) Go to /etc/mdm/Init/ and edit Default

8) Add before exit 0 these lines:

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi


Just restart your computer and next time you turn on it you have Numlock On always.


Stilloving from Argentina, Buenos Aires
stilloving
Level 1
Level 1
 
Posts: 5
Joined: Sat Jun 29, 2013 7:52 am

Linux Mint is funded by ads and donations.
 
Previous

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], niowluka and 24 guests