Cant get Firestorm to run in Mint 32 bit or 64 bit

Questions about applications and software
Forum rules
Before you post please read how to get help

Cant get Firestorm to run in Mint 32 bit or 64 bit

Postby ElectricRider on Tue Feb 05, 2013 9:17 am

This app can be run from the folder it's extracted in without being installed. It's a client viewer for Second Life, an online game. Downloaded from here: http://www.firestormviewer.org/downloads/ ( Edit: I'm using Mint 14 64 bit with XFCE. Firestorm is a 32 bit app)

This is what happens when i try to run the app and the steps I took so far.

Ran ./firestorm

dark@darksystems ~/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155 $ ./firestorm
Terminal output
Code: Select all
64-bit Linux detected.

Running from /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155

./firestorm: line 89: ./etc/register_hopprotocol.sh: No such file or directory

./firestorm: line 152: bin/do-not-directly-run-firestorm-bin: No such file or directory

*** Bad shutdown ($LL_RUN_ERR). ***

ERROR: ld.so: object '/home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/lib/libcrypto.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.

ERROR: ld.so: object '/home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/lib/libssl.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.

ERROR: ld.so: object '/home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/lib/libcrypto.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.

ERROR: ld.so: object '/home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/lib/libssl.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.

You are running the Firestorm Viewer on a x86_64 platform.  The

most common problems when launching the Viewer (particularly

'bin/do-not-directly-run-firestorm-bin: not found' and 'error while

loading shared libraries') may be solved by installing your Linux

distribution's 32-bit compatibility packages.

For example, on Ubuntu and other Debian-based Linuxes you might run:

$ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl


Tried the recommended command from above
dark@darksystems ~/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155 $ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl

Code: Select all
[sudo] password for dark:

Reading package lists... Done

Building dependency tree       

Reading state information... Done

Note, selecting 'ia32-libs' instead of 'ia32-libs-gtk'

Note, selecting 'ia32-libs' instead of 'ia32-libs-sdl'

E: Unable to locate package ia32-libs-kde


a google search shows that ia32-libs-kde is no longer being maintained.

Ran Mint Update. All updates completed.

Ran ./firestorm again from terminal in the folder where the app was extracted.

Ran "sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl" again and got the same error messages as above.

I also saw this thread and tried this suggestion and it did not work. http://blog.linuxmint.com/?p=2211 I got the idea to try that from this post: http://www.sluniverse.com/php/vb/techni ... 4-bit.html

Whats my next step?
Last edited by ElectricRider on Thu Feb 07, 2013 7:47 am, edited 2 times in total.
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Linux Mint is funded by ads and donations.
 

Re: Cant get Firestorm to run in Mint

Postby xenopeek on Tue Feb 05, 2013 9:24 am

I don't think you mentioned which Linux Mint version or desktop environment you are using (helps to give some details), but on Linux Mint 14 64-bit you would install 32-bit versions of common libraries with the package `ia32-libs-multiarch`.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15259
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Cant get Firestorm to run in Mint

Postby ElectricRider on Tue Feb 05, 2013 9:14 pm

Thanks, I just tried that and it's no good. I get the same error messages as above. I installed ia32-libs-multiarch from Synaptic and tried to run ./firestorm again. I'm using Mint 14 64bit Cinnamon with XFCE installed as my default DE.
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby ElectricRider on Wed Feb 06, 2013 2:21 am

No one has any ideas? Is Mint 14 64 bit that broken where this simple issue is not figured out?
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby xenopeek on Wed Feb 06, 2013 4:16 am

ElectricRider wrote:Is Mint 14 64 bit that broken where this simple issue is not figured out?

Excuse me? Look to the developers of this program please. From the Phoenix Firestorm README-linux.txt:
* Linux Operating System: A reasonably modern 32-bit Linux environment
is required. If you are running a 64-bit Linux distribution then
you will need its 32-bit compatibility environment installed, but
this configuration is not currently supported
.

If you remove the libraries it complains about from the program's lib folder (as those libraries are installed on your system as well by the ia32-libs-multiarch) at startup it no longer complains about these libraries but crashes with a X Windows System error. Which it also did for me before I fixed its libraries, just so you know I didn't introduce that :wink: I just managed to stop it complaining about its own libraries, but that was not the ultimate solution.
Code: Select all
libGL error: failed to load driver: i965
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
The program 'do-not-directly-run-firestorm-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 30 error_code 11 request_code 154 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** Bad shutdown ($LL_RUN_ERR). ***

You are running the Firestorm Viewer on a x86_64 platform.  The
most common problems when launching the Viewer (particularly
'bin/do-not-directly-run-firestorm-bin: not found' and 'error while
loading shared libraries') may be solved by installing your Linux
distribution's 32-bit compatibility packages.
For example, on Ubuntu and other Debian-based Linuxes you might run:
$ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15259
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby ElectricRider on Wed Feb 06, 2013 5:51 am

xenopeek wrote:
ElectricRider wrote:Is Mint 14 64 bit that broken where this simple issue is not figured out?

Excuse me? Look to the developers of this program please. From the Phoenix Firestorm README-linux.txt:
* Linux Operating System: A reasonably modern 32-bit Linux environment
is required. If you are running a 64-bit Linux distribution then
you will need its 32-bit compatibility environment installed, but
this configuration is not currently supported
.

If you remove the libraries it complains about from the program's lib folder (as those libraries are installed on your system as well by the ia32-libs-multiarch) at startup it no longer complains about these libraries but crashes with a X Windows System error. Which it also did for me before I fixed its libraries, just so you know I didn't introduce that :wink: I just managed to stop it complaining about its own libraries, but that was not the ultimate solution.


O.k. so it's not a Mint problem. I missed the above quote in the docs but i'm spoiled. Blame it on Microsoft. I'm used to all 32 bit apps simply working in a 64 bit os. So, it's not supported by the company. Wonderful. I know this does work with other 64 bit versions of Mint and the girl in the above thread I mentioned even got it working, so where do I look now?

It was also mentioned that if you compile from source it may work. I have never compiled from source from Mint. I have done so from Vector Linux but they have tools to make this easy. Do you think this might work in Mint?
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby xenopeek on Wed Feb 06, 2013 7:29 am

IDK, this program isn't using the "normal" way of doing a ./configure, make, sudo make install as how you usually compile from source painlessly. Having a read at the build instructions, http://hg.phoenixviewer.com/phoenix-fir ... _LINUX.txt, I'm not confident to tell you how to proceed. Doing an Internet search for it, turns up this page from two years ago: http://wiki.phoenixviewer.com/fs_compil ... ntu_builds. You can't use that anymore, but I hope it has become less complex to compile :shock: Perhaps there is an alternative to this program you could consider? One that does support for Ubuntu and for 64-bit?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15259
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby ElectricRider on Wed Feb 06, 2013 10:37 pm

I have tried a number of viewers that said were built for 64 bit, and so far, all of them give me the same errors.. None of these viewers are based on any 64 bit source form the original Second Life viewer, which they all used as a template, they only had a 32 bit version to work from. I have fought to get a viewer working in Vector Linux 64bit too with no luck. I may just have to abandon both 64 bit OS's and install the 32 bit versions.
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby ElectricRider on Thu Feb 07, 2013 7:12 am

As all these apps are very similar and use mostly the same core code, i decided to try Firestorm under Mint 14 Mate 32 bit. I get the following errors.. ( new errors)

Code: Select all
libGL error: failed to load driver: r600
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
The program 'do-not-directly-run-firestorm-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 30 error_code 11 request_code 154 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** Bad shutdown ($LL_RUN_ERR). ***


Note, I have no clue how to debug a program. Note also that I'm running Mint without a swap partition because I have 8 gigabytes of ram. Don't know if that has anything to do with the resources the app ran out of.. The program itself uses a max of 512 MB of ram while running, hardcoded into the system.. ( this is video ram) I would not think that just starting up the app uses a lot of ram.

If I use the LIBGL_DEBUG=verbose option i get this

Code: Select all
dark@dark-systems ~/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155 $ ./firestorm LIBGL_DEBUG=verbose
Running from /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155
./firestorm: line 89: ./etc/register_hopprotocol.sh: No such file or directory
2013-02-07T11:21:57Z INFO: llcommon/llerror.cpp(334) : (anonymous namespace)::LogControlFile::loadFile: logging reconfigured from /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/logcontrol.xml
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group Global - from location Default
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2377) : loadSettingsFromDirectory: Loaded settings file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/settings.xml
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group PerAccount - from location Default
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2377) : loadSettingsFromDirectory: Loaded settings file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/settings_per_account.xml
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group CrashSettings - from location Default
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2377) : loadSettingsFromDirectory: Loaded settings file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/settings_crash_behavior.xml
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group Warnings - from location Default
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2377) : loadSettingsFromDirectory: Loaded settings file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/ignorable_dialogs.xml
2013-02-07T11:21:57Z INFO: newview/llappviewerlinux.cpp(481) : initParseCommandLine: Language en
2013-02-07T11:21:57Z INFO: newview/llappviewerlinux.cpp(482) : initParseCommandLine: Location US
2013-02-07T11:21:57Z INFO: newview/llappviewerlinux.cpp(483) : initParseCommandLine: Variant UTF-8
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2560) : initConfiguration: Using command line specified settings filename: /home/dark/.firestorm/user_settings/settings_firestorm-release_v4.xml
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group Global - from location User
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_firestorm-release_v4.xml to load.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2391) : loadSettingsFromDirectory: Cannot load /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_firestorm-release_v4.xml - No settings found.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group CrashSettings - from location User
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_crash_behavior.xml to load.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2391) : loadSettingsFromDirectory: Cannot load /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_crash_behavior.xml - No settings found.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group Warnings - from location User
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings/ignorable_dialogs.xml to load.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2391) : loadSettingsFromDirectory: Cannot load /home/dark/.firestorm/user_settings/ignorable_dialogs.xml - No settings found.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group Global - from location Session
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2377) : loadSettingsFromDirectory: Loaded settings file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/settings_firestorm.xml
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group PerAccount - from location UserSession
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/account_settings_firestorm.xml to load.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2391) : loadSettingsFromDirectory: Cannot load /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/account_settings_firestorm.xml - No settings found.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group Global - from location User
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_firestorm-release_v4.xml to load.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2391) : loadSettingsFromDirectory: Cannot load /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_firestorm-release_v4.xml - No settings found.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group CrashSettings - from location User
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_crash_behavior.xml to load.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2391) : loadSettingsFromDirectory: Cannot load /home/dark/.firestorm/user_settings//home/dark/.firestorm/user_settings/settings_crash_behavior.xml - No settings found.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2342) : loadSettingsFromDirectory: Attempting to load settings for the group Warnings - from location User
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings/ignorable_dialogs.xml to load.
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(2391) : loadSettingsFromDirectory: Cannot load /home/dark/.firestorm/user_settings/ignorable_dialogs.xml - No settings found.
2013-02-07T11:21:57Z INFO: newview/llviewernetwork.cpp(219) : initialize: Last grid '' not configured
2013-02-07T11:21:57Z INFO: newview/llviewernetwork.cpp(226) : initialize: Default grid to util.agni.lindenlab.com
2013-02-07T11:21:57Z INFO: newview/llviewernetwork.cpp(397) : setGridChoice: setting util.agni.lindenlab.com
2013-02-07T11:21:57Z INFO: newview/llappviewerlinux_api_dbus.cpp(72) : grab_dbus_syms: Found DSO: libdbus-glib-1.so.2
2013-02-07T11:21:57Z INFO: newview/llappviewerlinux.cpp(307) : sendURLToOtherInstance: Call-out to other instance failed (perhaps not running): The name com.secondlife.ViewerAppAPIService was not provided by any .service files
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(3717) : initMarkerFile: Exec marker found: program froze on previous execution
2013-02-07T11:21:57Z INFO: newview/llappviewer.cpp(3208) : checkForCrash: Last execution froze, sending a crash report.
2013-02-07T11:21:57Z INFO: llcommon/llapp.cpp(652) : fork: Forked child process 5363
2013-02-07T11:21:57Z INFO: llcommon/llerror.cpp(334) : (anonymous namespace)::LogControlFile::loadFile: logging reconfigured from /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/logcontrol.xml
2013-02-07T11:21:57Z INFO: llcrashlogger/llcrashlogger.cpp(583) : init: Loading crash behavior setting
2013-02-07T11:21:57Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings/settings_crash_behavior.xml to load.
2013-02-07T11:22:01Z INFO: llcrashlogger/llcrashlogger.cpp(550) : updateApplication: Gathering logs...
2013-02-07T11:22:01Z INFO: llcrashlogger/llcrashlogger.cpp(186) : gatherFiles: Using log file from debug log /home/dark/.firestorm/logs/Firestorm.log
2013-02-07T11:22:01Z INFO: llcrashlogger/llcrashlogger.cpp(187) : gatherFiles: Using settings file from debug log
2013-02-07T11:22:01Z INFO: llcrashlogger/llcrashlogger.cpp(550) : updateApplication: Encoding files...
2013-02-07T11:22:01Z INFO: llcrashlogger/llcrashlogger.cpp(550) : updateApplication: Sending reports...
2013-02-07T11:22:01Z INFO: llcommon/llsdserialize_xml.cpp(407) : parse: LLSDXMLParser::Impl::parse: XML_STATUS_ERROR parsing:success
2013-02-07T11:22:01Z INFO: linux_crash_logger/linux_crash_logger.cpp(45) : main: Crash reporter finished normally.
2013-02-07T11:22:01Z INFO: llcommon/llapr.cpp(64) : ll_cleanup_apr: Cleaning up APR
2013-02-07T11:22:01Z WARNING: llcommon/llinitparam.cpp(94) : LLInitParam::Parser::parserWarning: Failed to parse parameter ""
2013-02-07T11:22:01Z WARNING: llui/lluicolortable.cpp(158) : LLUIColorTable::insertFromParams: PathfindingCharacterBeaconColor references a non-existent color
2013-02-07T11:22:01Z WARNING: llui/lluicolortable.cpp(158) : LLUIColorTable::insertFromParams: PathfindingDefaultBeaconColor references a non-existent color
2013-02-07T11:22:01Z WARNING: llui/lluicolortable.cpp(158) : LLUIColorTable::insertFromParams: PathfindingErrorColor references a non-existent color
2013-02-07T11:22:01Z WARNING: llui/lluicolortable.cpp(341) : LLUIColorTable::loadFromFilename: Unable to parse color file /home/dark/.firestorm/user_settings/colors.xml
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(814) : init: Configuration initialized.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(849) : init: LLCurl initialized.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(869) : init: Threads initialized.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(883) : init: UI initialized.
2013-02-07T11:22:01Z INFO: llui/llnotifications.cpp(1434) : LLNotifications::loadTemplates: Reading notifications template
2013-02-07T11:22:01Z INFO: llui/llnotifications.cpp(1511) : LLNotifications::loadTemplates: ...done
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(892) : init: Notifications initialized.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3454) : writeSystemInfo: Firestorm version 4.3.1
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3462) : writeSystemInfo: Local time: 2013-02-07T05:22:01 CST
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3465) : writeSystemInfo: CPU info:
processor   : 0
vendor_id   : AuthenticAMD
cpu family   : 21
model      : 16
model name   : AMD A8-4500M APU with Radeon(tm) HD Graphics   
stepping   : 1
microcode   : 0x6001116
cpu MHz      : 1400.000
cache size   : 2048 KB
physical id   : 0
siblings   : 4
core id      : 0
cpu cores   : 2
apicid      : 0
initial apicid   : 0
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc nonstop_tsc extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2
popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbya
id decodeassists pausefilter pfthreshold bmi1
bogomips   : 3793.02
clflush size   : 64
cache_alignment   : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro
 
processor   : 1
vendor_id   : AuthenticAMD
cpu family   : 21
model      : 16
model name   : AMD A8-4500M APU with Radeon(tm) HD Graphics   
stepping   : 1
microcode   : 0x6001116
cpu MHz      : 1400.000
cache size   : 2048 KB
physical id   : 0
siblings   : 4
core id      : 1
cpu cores   : 2
apicid      : 1
initial apicid   : 1
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc nonstop_tsc extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2
popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbya
id decodeassists pausefilter pfthreshold bmi1
bogomips   : 3793.02
clflush size   : 64
cache_alignment   : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro
 
processor   : 2
vendor_id   : AuthenticAMD
cpu family   : 21
model      : 16
model name   : AMD A8-4500M APU with Radeon(tm) HD Graphics   
stepping   : 1
microcode   : 0x6001116
cpu MHz      : 1400.000
cache size   : 2048 KB
physical id   : 0
siblings   : 4
core id      : 2
cpu cores   : 2
apicid      : 2
initial apicid   : 2
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc nonstop_tsc extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2
popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbya
id decodeassists pausefilter pfthreshold bmi1
bogomips   : 3793.02
clflush size   : 64
cache_alignment   : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro
 
processor   : 3
vendor_id   : AuthenticAMD
cpu family   : 21
model      : 16
model name   : AMD A8-4500M APU with Radeon(tm) HD Graphics   
stepping   : 1
microcode   : 0x6001116
cpu MHz      : 1900.000
cache size   : 2048 KB
physical id   : 0
siblings   : 4
core id      : 3
cpu cores   : 2
apicid      : 3
initial apicid   : 3
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc nonstop_tsc extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2
popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbya
id decodeassists pausefilter pfthreshold bmi1
bogomips   : 3793.02
clflush size   : 64
cache_alignment   : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro
 

->mHasSSE:     1
->mHasSSE2:    1
->mHasAltivec: 0
->mCPUMHz:     1400
->mCPUString:  AMD A8-4500M APU with Radeon(tm) HD Graphics    (1400 MHz)

2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3466) : writeSystemInfo: Memory info:
2013-02-07T11:22:01Z <mem>            Active:       703224
2013-02-07T11:22:01Z <mem>      Active(anon):       268312
2013-02-07T11:22:01Z <mem>      Active(file):       434912
2013-02-07T11:22:01Z <mem>     AnonHugePages:            0
2013-02-07T11:22:01Z <mem>         AnonPages:       267600
2013-02-07T11:22:01Z <mem>            Bounce:            0
2013-02-07T11:22:01Z <mem>           Buffers:        86884
2013-02-07T11:22:01Z <mem>            Cached:      1018356
2013-02-07T11:22:01Z <mem>       CommitLimit:      3871108
2013-02-07T11:22:01Z <mem>      Committed_AS:      1573608
2013-02-07T11:22:01Z <mem>       DirectMap2M:       897024
2013-02-07T11:22:01Z <mem>       DirectMap4k:        16376
2013-02-07T11:22:01Z <mem>             Dirty:           12
2013-02-07T11:22:01Z <mem> HardwareCorrupted:            0
2013-02-07T11:22:01Z <mem>          HighFree:      5626724
2013-02-07T11:22:01Z <mem>         HighTotal:      6927112
2013-02-07T11:22:01Z <mem>    HugePages_Free:            0
2013-02-07T11:22:01Z <mem>    HugePages_Rsvd:            0
2013-02-07T11:22:01Z <mem>    HugePages_Surp:            0
2013-02-07T11:22:01Z <mem>   HugePages_Total:            0
2013-02-07T11:22:01Z <mem>      Hugepagesize:         2048
2013-02-07T11:22:01Z <mem>          Inactive:       669496
2013-02-07T11:22:01Z <mem>    Inactive(anon):         5988
2013-02-07T11:22:01Z <mem>    Inactive(file):       663508
2013-02-07T11:22:01Z <mem>       KernelStack:         2656
2013-02-07T11:22:01Z <mem>           LowFree:       634924
2013-02-07T11:22:01Z <mem>          LowTotal:       815108
2013-02-07T11:22:01Z <mem>            Mapped:        98116
2013-02-07T11:22:01Z <mem>           MemFree:      6261648
2013-02-07T11:22:01Z <mem>          MemTotal:      7742220
2013-02-07T11:22:01Z <mem>           Mlocked:            0
2013-02-07T11:22:01Z <mem>      NFS_Unstable:            0
2013-02-07T11:22:01Z <mem>        PageTables:         5680
2013-02-07T11:22:01Z <mem>      SReclaimable:        52948
2013-02-07T11:22:01Z <mem>        SUnreclaim:        16336
2013-02-07T11:22:01Z <mem>             Shmem:         6824
2013-02-07T11:22:01Z <mem>              Slab:        69284
2013-02-07T11:22:01Z <mem>        SwapCached:            0
2013-02-07T11:22:01Z <mem>          SwapFree:            0
2013-02-07T11:22:01Z <mem>         SwapTotal:            0
2013-02-07T11:22:01Z <mem>       Unevictable:            0
2013-02-07T11:22:01Z <mem>      VmallocChunk:        89056
2013-02-07T11:22:01Z <mem>      VmallocTotal:       122880
2013-02-07T11:22:01Z <mem>       VmallocUsed:        31512
2013-02-07T11:22:01Z <mem>         Writeback:            0
2013-02-07T11:22:01Z <mem>      WritebackTmp:            0
2013-02-07T11:22:01Z <mem>         timestamp: 2013-02-07T11:21:57.53Z

2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3467) : writeSystemInfo: OS: Linux 3.5
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3468) : writeSystemInfo: OS info: Linux 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 i686
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3470) : writeSystemInfo: Timers: clock_gettime
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3348) : writeDebugInfo: Opening debug file /home/dark/.firestorm/logs/debug_info.log
2013-02-07T11:22:01Z INFO: llimage/llimagej2c.cpp(55) : getEngineInfo: Raw engine string was 'KDU v6.4.1'
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(917) : init: J2C Engine is: KDU
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(918) : init: libcurl version is: libcurl/7.21.1 OpenSSL/1.0.0d zlib/1.2.5 c-ares/1.7.1
2013-02-07T11:22:01Z WARNING: llxml/llcontrol.cpp(921) : LLControlGroup::loadFromFile: Cannot find file /home/dark/.firestorm/user_settings/settings_crash_behavior.xml to load.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(960) : init: UI initialization is done.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(1009) : init: Hardware test initialization done.
2013-02-07T11:22:01Z INFO: llimage/llimagej2c.cpp(55) : getEngineInfo: Raw engine string was 'KDU v6.4.1'
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(952) : initCache: Headers: 572662 Textures size: 1310 MB
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/0
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/1
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/2
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/3
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/4
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/5
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/6
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/7
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/8
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/9
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/a
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/b
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/c
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/d
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/e
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1521) : purgeAllTextures: Deleting files in directory: /home/dark/.firestorm/cache/texturecache/f
2013-02-07T11:22:01Z WARNING: llcommon/llapr.cpp(296) : ll_apr_warn_status: APR status 2: No such file or directory
2013-02-07T11:22:01Z WARNING: llcommon/llapr.cpp(532) : open:  Attempting to open filename: /home/dark/.firestorm/cache/texturecache/texture.entries
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1546) : purgeAllTextures: The entire texture cache is cleared.
2013-02-07T11:22:01Z INFO: newview/lltexturecache.cpp(1564) : purgeTextures: TEXTURE CACHE: Purging.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(4149) : initCache: VFS CACHE SIZE: 409 MB
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(251) : LLVFS: Attempting to open VFS index file /home/dark/.firestorm/cache/index.db2.x.1
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(252) : LLVFS: Attempting to open VFS data file /home/dark/.firestorm/cache/data.db2.x.1
2013-02-07T11:22:01Z WARNING: llcommon/llfile.cpp(125) : warnif: Couldn't remove '/home/dark/.firestorm/cache/index.db2.x.1' (errno 2): No such file or directory
2013-02-07T11:22:01Z WARNING: llcommon/llfile.cpp(125) : warnif: Couldn't remove '/home/dark/.firestorm/cache/index.db2.x.1' (errno 2): No such file or directory
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(655) : presizeDataFile: Pre-sized VFS data file to 428867584 bytes
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(555) : LLVFS: Using VFS index file /home/dark/.firestorm/cache/index.db2.x.1
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(556) : LLVFS: Using VFS data file /home/dark/.firestorm/cache/data.db2.x.1
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(251) : LLVFS: Attempting to open VFS index file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/static_index.db2
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(252) : LLVFS: Attempting to open VFS data file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/static_data.db2
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(555) : LLVFS: Using VFS index file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/static_index.db2
2013-02-07T11:22:01Z INFO: llvfs/llvfs.cpp(556) : LLVFS: Using VFS data file /home/dark/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155/app_settings/static_data.db2
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(1030) : init: Cache initialization is done.
2013-02-07T11:22:01Z INFO: newview/llappviewer.cpp(3232) : initWindow: Initializing window...
2013-02-07T11:22:01Z INFO: newview/llviewerwindow.cpp(1599) : LLViewerWindow: NOTE: ALL NOTIFICATIONS THAT OCCUR WILL GET ADDED TO IGNORE LIST FOR LATER RUNS.
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(114) : ll_try_gtk_init: Starting GTK Initialization.
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(134) : ll_try_gtk_init: GTK Initialized.
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(135) : ll_try_gtk_init: - Compiled against GTK version 2.4.14
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(139) : ll_try_gtk_init: - Running against GTK version 2.24.13
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(155) : ll_try_gtk_init: - GTK version is good.
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(427) : createContext: createContext, fullscreen=0 size=1024x738
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(443) : createContext: Compiled against SDL 1.2.14
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(449) : createContext:  Running against SDL 1.2.14
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(465) : createContext: Original aspect ratio was 1600:900=1.77778
2013-02-07T11:22:01Z INFO: llwindow/llwindowsdl.cpp(628) : createContext: createContext: creating window 1024x738x32
libGL error: failed to load driver: r600
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
The program 'do-not-directly-run-firestorm-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 30 error_code 11 request_code 154 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** Bad shutdown ($LL_RUN_ERR). ***
dark@dark-systems ~/Downloads/Phoenix_Firestorm-Release_i686_4.3.1.31155 $


BTW, why does Mint think i only have 2 CPU cores when i have 4 ?
Last edited by ElectricRider on Thu Feb 07, 2013 7:24 am, edited 1 time in total.
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby xenopeek on Thu Feb 07, 2013 7:21 am

No, I also got the "insufficient resources" error on my Linux Mint 64-bit install... And I have 16 GiB RAM, so that can no be the problem (unless somehow it needs more than 16 GiB RAM :shock:).
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15259
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Cant get Firestorm to run in Mint ( 32 bit app on 64 bit

Postby ElectricRider on Thu Feb 07, 2013 7:25 am

You posted while i was editing.. you may wanna see the above again as I've added more info.

Edit: I get the same exact errors with the Catznip viewer and the official SecondLife viewer, and the Phoenix viewer.
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Re: Cant get Firestorm to run in Mint 32 bit or 64 bit

Postby xenopeek on Thu Feb 07, 2013 9:00 am

There's nothing it there that means anything to me, perhaps the Phoenix Firestorm developers have place where you can ask for support on this?

As to the cores; if you installed Linux Mint 13 32-bit, you'll need to install the PAE kernel to use multiple cores. Linux Mint 14 32-bit comes preinstalled with that. To do so, install the packages linux-image-generic-pae and linux-headers-generic-pae. From the terminal you could do that with:
Code: Select all
apt update
apt install linux-image-generic-pae linux-headers-generic-pae
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15259
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Cant get Firestorm to run in Mint 32 bit or 64 bit

Postby ElectricRider on Thu Feb 07, 2013 9:44 am

I'm using Mint 14, but installed that package anyway. Thanks.. funny thing is even though you say it should be preinstalled, it did install one component it didn't have before and it updated one. System information shows 4 cores even before I ran the command you gave for the pae extentions. But it seemed the terminal looks at different data to determine the number of cores.
ElectricRider
Level 4
Level 4
 
Posts: 205
Joined: Tue Dec 07, 2010 8:39 pm

Re: Cant get Firestorm to run in Mint 32 bit or 64 bit

Postby gjbivin on Tue Jun 25, 2013 7:05 pm

After trying just about every "fix" I could find to get Firestorm running (Mint 15 64-bit), I finally got it going with:
Code: Select all
sudo bash firestorm

(in the Firestorm folder). Apparently the default sh shell handler has some incompatabilities with the bash shell handler and gives syntax errors in certain if statements. I don't know WHY I had to run it with sudo; probably some permission problems with files or folders -- I am a linux newbie (although I have a lot of experience running and programming in Windows) so will have to research it further. This was running in Terminal; next step is to put the command in a launcher.
gjbivin
Level 1
Level 1
 
Posts: 1
Joined: Tue Jun 25, 2013 6:48 pm

Re: Cant get Firestorm to run in Mint 32 bit or 64 bit

Postby DonnaSaenz on Wed Oct 16, 2013 4:55 pm

I have been searching (painfully) for the same solution, and wish to share what I have learnt so far ...

I think like most people, I wish to run 64bit Linux and at the same time, hoping to run all my apps whether they are in 32bit or 64bit or not.

In this case, Secondlife on Linux x64. I figured out the following options:

A. Install ia32-libs and you will be able to run a large number of 32bit Linux viewers including the one from SL, and Firestorm which are 32bit app.

i.e. apt-get install ia32-libs


B. Install Kokua or Singularity Viewer both offer 32 or 64bit version:

http://wiki.kokuaviewer.org/wiki/Kokua/Downloads

http://www.singularityviewer.org/downloads


C. If you really enjoy using Firestorm, you will notice that the 32bit app has the following problems:

1. Streaming is not working. This is due to the fact that required gstreamer ugly and bad are not multi-arched. Ubuntu / Linux Mint (up to version 15) are the same situation. So, you will not be able to listen to music when you enter a region or parcel in SL.

2. SLURL is not working. For example, from Chrome browser, you click something life secondlife://athena/10/10/10 the "place profile" will not popup like Windows or OSX.

So, lucky, with Linux Mint 15 (I use Cinnamon), you can actually compile your own 64bit FS and have everything working!!

The procedure here is straightforward if you follow exactly step by step:

http://wiki.phoenixviewer.com/fs_compil ... it_kubuntu

The only thing you may want to change is to edit indra/cmake/00-Common.cmake, search for "Werror" and add the line in bold so that it will compile all the way:

set(GCC_DISABLE_FATAL_WARNINGS TRUE)

if (NOT GCC_DISABLE_FATAL_WARNINGS)
set(GCC_WARNINGS "${GCC_WARNINGS} -Werror")
endif (NOT GCC_DISABLE_FATAL_WARNINGS)

After an hour of compilation, you should be able to find the installable package under build-linux-i686/newview
You can bzip2 the file and install...

When done, make sure you remove (or backup) your ~/.firestorm directory and start clean. I ran into a lot of problems when forgotten to do that.

SLVoice will not work, you will have to copy the binaries from Secondlife 32bit package, for example:

cd /opt/firestorm/bin
ln -sf /opt/secondlife/bin/SLVoice .
cd ..
ln -sf /opt/secondlife/lib .

If this doesn't work, make sure that the SecondLife pacakge itself is working with Voice. Or you can quickly run SLVoice directly from command line to check.


The last annoyance has to do with Chrome Browser and xdg-open, follow this link for a solution:

http://community.secondlife.com/t5/Seco ... d-p/941829


I think FS maybe the fastest viewer, so, the above effort is worth it. Just my $0.02 and let me know if you have better way to do this...
DonnaSaenz
Level 1
Level 1
 
Posts: 1
Joined: Wed Oct 16, 2013 4:18 pm

Re: Cant get Firestorm to run in Mint 32 bit or 64 bit

Postby monaeberhardt on Sat Feb 22, 2014 7:46 am

Actually, Firestorm is based on the official Second Life viewer and currently there is no "stable" 64-bit version of either. FS started working on a 64-bit build for Windows and Linux, but there are still some issues. Keep in mind that Havok, the physics engine that SL uses, doesn't yet have a 64-bit version, or at least that's what Oz Linden said.
User avatar
monaeberhardt
Level 1
Level 1
 
Posts: 3
Joined: Tue Nov 19, 2013 6:17 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 16 guests