[SOLVED] Automount opens all drives as directory windows

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] Automount opens all drives as directory windows

Postby nopuppy on Sun Dec 16, 2012 10:32 am

Pardon the newbie speak. I installed Mint 14.1 MATE 64-bit. I have several hard drives with various partitions and after some research used mountmanager to change the /etc/fstab so they would automount at start. (I wish there was some English documentation on mountmanager, I did a lot of playing with it to figure it out.) Now when I boot up they mount fine, but my desktop is covered with the folders showing their contents.

Is there a step I've missed that would prevent those directories from opening automatically. It's a bit of a nuisance to have to close them all before starting my work. Thanks.

nopuppy
Last edited by nopuppy on Sun Dec 16, 2012 2:33 pm, edited 3 times in total.
nopuppy
Level 1
Level 1
 
Posts: 2
Joined: Sun Dec 16, 2012 10:26 am

Linux Mint is funded by ads and donations.
 

Re: Automount opens all drives as directory windows

Postby altair4 on Sun Dec 16, 2012 10:58 am

In order for anyone to help you they will need to see the damage mountmanager has done so please post the output of the following commands:
Code: Select all
cat /etc/fstab

Code: Select all
sudo blkid -c /dev/null
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5986
Joined: Tue Feb 03, 2009 10:27 am

Re: Automount opens all drives as directory windows

Postby nopuppy on Sun Dec 16, 2012 11:47 am

altair4 wrote:In order for anyone to help you they will need to see the damage mountmanager has done so please post the output of the following commands:
Code: Select all
cat /etc/fstab

Code: Select all
sudo blkid -c /dev/null


Thanks. Here's the output from those:

cat /etc/fstab

UUID=228d9328-00cb-4c3c-babc-0eb636a380bf swap swap sw 0 0
UUID=1300d096-8d7b-42a5-bb81-30e57f5cf23d / ext3 defaults 0 1
UUID=b2eaa6cd-328e-46c0-8484-aca4db64c8f5 /media/brian/Brian ext3 defaults 0 0
UUID=dd8dca79-ca22-4902-b085-0bd931bb38d7 /media/brian/head ext3 defaults 0 0
UUID=0d328d3a-65cb-4695-a695-e96dd5e59ec7 /media/brian/ear ext3 defaults 0 0
UUID=41df01ee-2ada-432a-9c67-95a3c5a36358 /media/brian/eye ext3 defaults 0 0
UUID=9431dfeb-2694-4a0b-9093-deb013548677 /media/brian/heart ext3 defaults 0 0

blkid -c /dev/null returns nothing, terminal just sits there blank. I went to look in the /etc folder and when I hit Computer I get an error message that my floppy disk can't be mounted, though I don't have a floppy drive, if that's significant. Thanks for your help.
nopuppy
Level 1
Level 1
 
Posts: 2
Joined: Sun Dec 16, 2012 10:26 am

Re: Automount opens all drives as directory windows

Postby altair4 on Sun Dec 16, 2012 12:10 pm

blkid -c /dev/null returns nothing, terminal just sits there blank.

Because you didn't preface that command with sudo:
Code: Select all
sudo blkid -c /dev/null

If you did run the command above and get no output then your problems are more serious than having mount icons on the desktop. Is this a new install?

Anyway, Let's take this as an example:
UUID=b2eaa6cd-328e-46c0-8484-aca4db64c8f5 /media/brian/Brian ext3 defaults 0 0

[1] Unmount the partition:
Code: Select all
sudo umount /media/brian/Brian

[2] Create a new mount point:
Code: Select all
sudo mkdir /mnt/Brian

[3] Edit fstab as root:
Code: Select all
gksu gedit /etc/fstab

Note: I have no idea what Mate calls it's text editor so substitute its name for gedit

[4] And change the line to this:
UUID=b2eaa6cd-328e-46c0-8484-aca4db64c8f5 /mnt/Brian ext3 defaults 0 0

[5] Save fstab and then run the following command:
Code: Select all
sudo mount -a


Your partition should now be mounted to /mnt/Brian and it's mount icon should no longer be on the desktop.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5986
Joined: Tue Feb 03, 2009 10:27 am

Re: Automount opens all drives as directory windows

Postby baptiste on Sun Dec 16, 2012 12:17 pm

You could disable floppy drive and even floppy controller in BIOS (if applicable), the floppy hardware interface dates back to the 1980s and is so dumb (even for the time) that it does not know if a floppy drive is present or not. (it does not know either if a floppy is inserted or not, whereas some old computers could)

For your other problem, maybe it's to do with the configuration of Caja, the file manager.
I've looked at options : Edit, Preferences, Media, "Browse media when inserted"

I'd say it is most certainly this ; what happens to you everytime you log in is similar to when you plug in an USB drive to your computer : the content shows up.

mountmanager problably put a script or scripts somewhere that trigger this "mounting of media" event when you log in.
perhaps something to do with udev, so you could look in /etc/udev/rules.d if there's something.

From apt-cache show mountmanager in Mint 13 :
Description-en: User-friendly management of disks and partitions
The basic functionalities of MountManager are:
- Mount and unmount partitions (ext3/2, ntfs, swap, fat, reiserfs, iso9660,
udf, ...)
- Show all logical and physical disks
- Change config file /etc/fstab
- Descriptions of options and other settings of mounting
- Restoration system
- Images mounting and unmounting (Nrg, Mdf , Ccd, Bin , etc)
- Udev rules creation
- Disk wizard
- Etc...
.
Plugins are supported and there is good English and Russian documentations to
help develop new plugins.
Homepage: http://code.google.com/p/linuxtuner/
baptiste
Level 2
Level 2
 
Posts: 98
Joined: Sun Jan 22, 2012 12:25 am

Re: Automount opens all drives as directory windows

Postby altair4 on Sun Dec 16, 2012 1:23 pm

I'd say it is most certainly this ; what happens to you everytime you log in is similar to when you plug in an USB drive to your computer : the content shows up.

All of the partitions that he has automounting and showing up on the desktop are defined by lines like this in his fstab:
UUID=b2eaa6cd-328e-46c0-8484-aca4db64c8f5 /media/brian/Brian ext3 defaults 0 0

*** Mount a partition in /media or your home directory and a mount icon appears on the desktop.

*** Mount them anywhere else ( my suggestion was /mnt ) and they will not show up on the desktop.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5986
Joined: Tue Feb 03, 2009 10:27 am


Return to Software & Applications

Who is online

Users browsing this forum: Empirst and 19 guests