Black screen when boot from live CD

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Black screen when boot from live CD

Postby brunnhilde on Sat Feb 04, 2012 7:52 pm

I just got a Dell desktop with Windows 7 64-bit, and I've been trying all morning to install LMDE unsuccessfully. I first tried to boot from a USB drive but after selecting USB at the BIOS screen all I got was a black screen. Then I burned the ISOs (gnome & xfce), the sums were correct, the DVDs showed the right folders (casper & isolinux), I booted from the DVD drive and I got to the Mint screen showing the initial menu to choose between default, recovery mode, etc. I've chosen both the default and recovery mode and after that I get again a black screen. No mouse pointer, no message of any type, no error, it simply stays black and I have to reboot. I've done this a dozen times now.

The last thing I tried was an old Ubuntu CD to see if the WUBI installer could help. I restarted and I got the boot screen with Windows and Ubuntu to choose from. I chose Ubuntu and then again, the black screen.

EDIT: As I was typing this, after about 5 minutes of the black screen I hear the familiar Ubuntu splash intro (which Mint lacks), but the screen stays black. So probably the distro boots fine and I'm just not able to see it. Could it be a problem with the video card? It's a GeForce GT 525M and according to Nvidia's site Linux supports this model. I'm not exactly new with LMDE but since this is the first time I've had problems during installation I thought I'd ask.

Thank you in advance.

EDIT: Okay, I can boot now. I just added argument "i915.modeset=0" and was able to see the live desktop.
brunnhilde
Level 1
Level 1
 
Posts: 24
Joined: Thu Dec 23, 2010 10:40 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 6 guests