Slow Internet

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Slow Internet

Postby Sarriman on Sat Aug 18, 2012 7:52 pm

Hello!

I 've recently installed, in my Dell Inspiron N5110, the Linux Mint 13 (Maya).
Everything besides one problem works just great!
The problem is that most of the times, the internet (downloading through console, downloading through soft-manager, browsing, etc) is extremly poor. Sometimes i am waiting over one minute for the google page to load.
I tried to do some ping test through http://www.pingtest.net/ but the proccess cannot even start cause "a firewall maybe blocking the connection".

I ve search around for drivers but i didnt come up with anything to solve my problem.
Any help would be greatly appreciated!!

Tell me if you need any information about something in the laptop or in the OS.

Thank you in advance!

P.S. I have a dual boot ( Win7 + Maya ) and the internet speed in Win7 is always just great!
Sarriman
Level 1
Level 1
 
Posts: 3
Joined: Sat Aug 18, 2012 12:23 pm

Linux Mint is funded by ads and donations.
 

Re: Slow Internet

Postby cwsnyder on Sat Aug 18, 2012 9:38 pm

Are you connecting through a wired Ethernet connection (RJ-45 CAT-5 or 6), or wireless? WPA-2 (PSK) if wireless? What router?

Have you tried using a wired connection instead of wireless? (My bet is that you are connecting only wirelessly.)

Have you installed a Linux firewall, or are you depending on the firewall in your router?

Are you using a high speed connection? What type? (ie. DSL, cable modem, satellite ISP, broadcast broadband using a special antenna, T-1 line, or other)

Have you ran a speed test through your browser? (Google 'Internet speed test' for information on speed test providers.) What were the results?
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Slow Internet

Postby Sarriman on Sun Aug 19, 2012 5:24 am

I am connecting through a wirelless connection. I dont think the router is a problem cause i have tried with more than 3 routers/adsl lines and everywhere i am having the same problem.
I have not isntalled any linux firewall and i dont think that router's firewall is causing me any of that problems cause when i boot with Win7 everything works right.
I am using an adsl connection (24 Mbps). When i run a speedtest through the speedtest.net alla the speeds seems fine. The !ping!test is something that i cant do cause as the error massage says "maybe some firewall is blocking the connection".
Image

Thank you for your answer and your time!
Sarriman
Level 1
Level 1
 
Posts: 3
Joined: Sat Aug 18, 2012 12:23 pm

Re: Slow Internet

Postby cwsnyder on Sun Aug 19, 2012 6:34 am

Do you have a wired Ethernet connection, and have you tried it instead of the wireless connection? Your replies seem to point to a driver problem with your wireless connection.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Slow Internet

Postby Sarriman on Sun Aug 19, 2012 7:03 am

I havent tried to use an ethernet connection, and i dont think thats a driver problem cause sometimes it works just great.
The result from the speedtest now is pathetic :( Image .
I am thinking about packet loss or something but still dont know.Plz help cause all this thing is very sad and i am thinking of changing a distro.

Thank you for your time and for your answer!
Sarriman
Level 1
Level 1
 
Posts: 3
Joined: Sat Aug 18, 2012 12:23 pm

Re: Slow Internet

Postby Horor on Fri Aug 24, 2012 8:53 am

Sarriman wrote:I havent tried to use an ethernet connection, and i dont think thats a driver problem cause sometimes it works just great.
The result from the speedtest now is pathetic :( Image .
I am thinking about packet loss or something but still dont know.Plz help cause all this thing is very sad and i am thinking of changing a distro.

Thank you for your time and for your answer!


hi,
Your ping is very very slow So contact your Service provider and change the settings in your modem or otherwise you can reset your modem and do ping test using online sites like http://www.whoisxy.com/ ,ping should between 20ms to 40ms for a good internet connection,So I recommend you to contact your ISP........
Horor
Level 1
Level 1
 
Posts: 1
Joined: Fri Aug 24, 2012 8:48 am

Re: Slow Internet

Postby Oscar799 on Sun Aug 26, 2012 5:38 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8895
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: Cchilaquil and 9 guests