Problems with ADSL modem

Questions about cabled networking
Forum rules
Before you post please read how to get help

Postby nex92 on Mon May 07, 2007 8:27 am

Hi there!

After reading the previous posts, I tried to set up my Internet connection. I also have an ADSL modem, but no router. My provider does not give me a static address. I then have to connect using an identifier and a password.
In the connection panel, I have two items : a wired connection and a modem one. Following the previous posts, I modified the figures in the wired connection, but it does not allow me to enter an identifier. So, I presume I shouldn't have modified these figures but just played with the second one? But now, the set up of my ethernet card is screwed!
I also tried the pppoeconf utility, but it looks like the command is unknown.
Any hint?
nex92
Level 1
Level 1
 
Posts: 10
Joined: Sun Apr 29, 2007 12:57 pm

Linux Mint is funded by ads and donations.
 

Postby Boo on Mon May 07, 2007 8:47 pm

first this post would be better addressed if you had started it as a new topic.

@ moderator: split please.

what type of ADSL modem have you got? how do you connect to it (usb, ethernet...)?
was your modem working before you installed mint?

I suspect you connect via Ethernet and your modem holds your identifier and password. so you have to just set a static IP on your network card in the range that the modem uses then you can configure the modem.
The modem uses NAT to translate the address your modem has to the address the ISP gives it.

I will now stop confusing you and wait for more info.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby nex92 on Tue May 08, 2007 3:03 am

Hi Boo

The modem I'd like to connect with is a Bewan ADSL Ethernet model. This modem works as I use it with XP. I previously had a Mandriva and it was working fine. As a matter of fact, there is a wizard in Mandriva where you just select your ISP and the type of your modem, then you just give your identifier and password and everything is set up. 8)
I ran an ipconfig with XP and I got 192.168.0.1 with a submask of 255.255.255.0. Under XP, I have a ppoe connection wich keeps my identifier & password.
At the first boot with Mint, I had two entries in the connection menu : one is my ethernet card (a.k.a. "wired") and the other one is "modem". As I've mentionned, I've screwed the settings of the Ethernet card.
Basically, what I need is :
- find the settings of the "wired connection"
- find the settings of the "modem connection".
Unfortunately, it looks like I've destabilized Mint (because of the local loop?) and when I play around with the network settings, I'm unable t orun the control panel anymore, and I cannot shut down.

Sorry, Boo, for continuing a previous post : I thought it was more convenient to have one thread with posts dealing of the same topic. I won't do that again!
Thanks in advance
nex92
Level 1
Level 1
 
Posts: 10
Joined: Sun Apr 29, 2007 12:57 pm

Postby Boo on Tue May 08, 2007 9:37 am

so first clear your /etc/network/interfaces file and just leave the lo interfaces.

auto lo
iface lo inet loopback

restart networking or just reboot.

now that everything is cleaned up try running pppoeconf and follow the questions.

sudo pppoeconf.

I found this post:
http://doc.ubuntu-fr.org/materiel/modem ... n_ethernet
it is in French, but i got the gist. i hope you can read it.
or maybe some nice French user can help.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby nex92 on Tue May 08, 2007 4:01 pm

Thanks, Boo, for the precious material you're giving. Actually, I did find the post you mentioned... but a bit too late :oops: ! Lucky me, I'm French and I won't have any trouble following the instructions.
I'll give a try to what you're writing and I'll let you know.
nex92
Level 1
Level 1
 
Posts: 10
Joined: Sun Apr 29, 2007 12:57 pm


Return to Ethernet

Who is online

Users browsing this forum: No registered users and 7 guests